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Type III Roadway Lens Design 
 

 

Tutorial Overview 
We will develop a smooth Type III Roadway Lens by lofting together multiple aimed lens profiles. The Type III application 
is a standard forward-throw (asymmetric) street requirement with the goal of reducing the house-side light while spreading 
the light up and down the roadway to maximize pole spacing. 

Topics Covered 
● Lens Design Tools 
● Lofting 
● Optical design processes 

Skill Level -  Advanced 

Interface -  Photopia 

Units -  Metric (mm) 

Estimated Completion Time -  120 minutes 

  

  

www.ltioptics.com 1 photopia@ltioptics.com 

http://www.ltioptics.com/


1/8/2019 Type III Roadway Lens Design - Google Docs

https://docs.google.com/document/d/126rnGFb-6qlnqTZOXiMwOgsa-ZndwL1g-MyOZ_sWel4/edit#heading=h.a7ac7bdvbfmn 2/20

 

Model Setup 
1. Open Photopia (the stand alone version) and go to File > New to begin a new project. 
2. Change your model units to be in millimeters by going to Settings > Project Settings, and selecting “Millimeters” 

as the Length Units. Close the Project Settings window. 
3. In this tutorial we will be working in the local construction planes (CPlanes) rather than the world coordinate 

system (WCS), at the bottom of the Photopia Window toggle the coordinate system button so it says “CPlane”: 

 
4. Save your project as “Type III Roadway Lens”. 
5. We will be designing the lens around the Cree XP-L, to add this LED to your model go to File > Import Lamp and 

select the “XL-L-5700K.LAMP” file. Insert it at the default insertion point of “0,0”. 
6. Create an Illuminance Plane that will be large enough so we can see the overall broad pattern we expect to create 

from our lens design. The plane will be 8m square, 1m below our optic. In the CAD View, go to Top view, go to 
Draw > Illuminance Plane (or type “ip” into the command line). In the Command line you will be prompted to select 
the lower left corner of the plane, type “-4000,-4000,-1000”, hit enter. For the upper right corner type 
“4000,4000,-1000”, enter. The plane description will be “8m x 8m, 1m below”. Hit enter to accept the default cell 
extents and finish the illuminance plane. 

7. Click the Zoom Extents button (or type “ze” into the command line) to zoom out and see your new illuminance 
plane. Toggle on the “Illum.Planes” button at the bottom of your screen. 

8. Select one of the edges of your plane (it will turn pink) and in the properties window on the right, under the Display 
section, change Display Plot to be “True”. In the CAD view hit the escape button to deselect your illuminance 
plane. 

9. Go to Analysis > Specify Photometric Output, go to the Photometric Report tab. Change the Report Type from 
Indoor to Roadway, change the Horizontal angle set to be “0” and the Vertical angle set to be “0(2.5)90”. We will 
start our roadway design by creating a revolved lens, so the horizontal angle set is symmetric. We increase the 
resolution in the vertical angles since we will be trying to create a strong batwing which will have a quickly 
changing intensity profile. Click “OK” to close the Photometric Output Specification window. Note - we will change 
these photometric settings later on in the design when we develop our asymmetric optic. 

10. Go to Analysis > Specify Raytrace Settings. On the Raytracing tab change the number of Initial Source Rays from 
2.5mil to 20mil. When we design our three primary lens profiles we will be trying to achieve a similar intensity 
profile around nadir and having more rays will give us a smoother intensity profile at those low angles where we 
don’t have as much light aimed. Click “OK” to close the Raytrace Settings window. 

11. Save the project. 
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Diagonal Lens Profile Design with Undercut 
Note  - The goal with this optic will be to achieve a Type III Medium distribution. This will require our peak intensity 
to occur around 70° vertically and 70° horizontally. Since we want to achieve a rectangular pattern the primary 
throw of our optic will be diagonally to the corner of the target area. Ultimately we will design four profiles which 
we will loft together to create a single smooth optic. In this tutorial these profiles will be called “Across”, 
“Diagonal”, “Curb”, and “Back” and will be oriented like this: 

 

 
We will start with a revolved version of the “Diagonal” profile because it is the one that needs to achieve the 
widest throw. After completing the Diagonal lens design we will use that lens profile geometry as a foundation for 
our Across and Curb profiles. 
 

12. In the CAD View, Toggle off your “Illum.Planes” button, go to the Right View, and Zoom Extents, you should only 
see the LED. Zoom out a few times to give yourself some working room to develop the lens profile. 

13. The input face of our lens will be a hemisphere with a 3.5mm radius centered on the LED. The lens will have a 
minimum thickness of 2.0mm. 
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14. Go to Draw > Arc, type “c” for center, enter. Type “0,0”, enter. The start point will be directly below the LED, type 
“0,-3.5”, enter. The input face is a hemisphere, for the included angle type “90”, enter. 

 
15. Go to Design > Lens > Revolved, the command line prompt will ask for the line type, type “S” to select a curve hit 

enter. 
16. The LED was inserted at 0,0, for the lamp center hit enter for the default of 0,0 (or type in “0,0” and enter). 
17. Select the arc, enter. 
18. The number of prism steps/curve segments will be 100 so we have a clean and smooth lens profile. Type “100”, 

enter. 
19. The start aiming angle will be at nadir, straight below the luminaire. Type “0”, enter. 
20. The end aiming angle will be slightly beyond our goal of 70° so we can taper off the beam at the edge of our 

target area. Type “76”, enter. 
21. For the aiming angle increment we will work in 1 degree steps so we have a smoother beam. Type “1”, enter. 
22. The minimum thickness of our lens is 2.0mm. Type “2.0”, enter. 
23. The number of Revolve segments will be 90. Type “90”, enter. 
24. You have completed the parameters necessary for Photopia to generate your revolved lens profile. All of the 

parameters above can be changed at any time and the lens will rebuild based on the updated parameters. Your 
lens in the Right view should look like this: 

 
25. Select the lens (it will turn pink and the aiming lines will be displayed). 
26. By default the lens profile type will be stepped, like what we would use for a Fresnel lens design. This optic will be 

smooth instead. In the Properties window under Optical Parameters change the Profile Type to be “Smooth”. 
27. Also be default, the inside and outside lens profiles will be closed at the start and end. For this lens we want the 

end to be closed (at the top of the lens), but not the start. In the Properties window under Optional Geometry 
change Close Start to be “No”. Move the mouse back to the CAD space and hit escape to deselect the lens. The 
lens now looks like this: 
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28. Assign a lens material by going to Edit > Design Properties, switch to the Refractive Tab, select the REFR-Main 

layer and click Assign Material. Scroll down to the Generic Manufacturer section and select the “ACRYLIC1” 
material and click OK. Click OK to close the Design Properties Window. 

29. Save the project. 
30. Begin the analysis by either clicking on the calculator button, going to Analysis > Begin Analysis, or hitting Ctrl+B. 

Your illuminance plane and polar plot will look like this: 

 
31. While the pattern is smooth, we want a very wide batwing distribution to push light up and down the roadway to 

maximize our pole spacing. So we need to reduce the intensity at nadir and increase the intensity at 70° vertical. 
Toggle off the “Illum.Planes” button, go to Right view, and Zoom Extents. 

32. Select the lens and in the Properties window in the Weight Section change the Weight Exponent to “1.55” this will 
place increase the percent of lens aimed towards the higher angles and decrease the amount aimed at the lower 
angles. 

33. Your lens is now wider with a more defined dip in the center directly in front of the LED: 

 
34. Save the project. 
35. Begin the analysis and view your results: 
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The lens now produces a smooth, but much wider, beam with the peak occurring near 70°. 

 

Diagonal Lens Profile Design without Undercut 
36. While the Diagonal lens design is producing a good quality beam, it has an undercut at the top of the outside face 

which would either need to be resolved in a secondary CAD step, or now during the design process. We will 
correct this now in order to maintain beam control of the high angle light that leaves the LED. Toggle off the 
“Illum.Planes” button, go to Right view, and Zoom Extents. 

37. To better visualize this undercut use the following trick. Go to Settings > Layers, create a New Layer, rename it 
“Construction”, make the color “Yellow”, line type “DASH”, and line width “3”. Select the Construction layer and 
click “Set Current”. Click OK to close the Layer Window. 

38. Go to Draw > Line (or type “l” into the command line). The first point will be “-10,-1.5”, enter. The second point will 
be “10,-1.5”, enter. Enter to end. The dashed line represents a standard connecting flange thickness that would 
eventually connect the array of individual roadway optics so they can be molded as one part. As you see below, 
the lens has an undercut above the horizontal construction line. You can add multiple construction lines to help 
sketch the issue, since the Construction layer has a Non Optical layer type, these lines will not interact with the 
raytrace: 

 
39. To remove the undercut we will remove optical control from the top of the outside profile and add optical control to 

the top of the inside hemisphere. Select the lens and go to View > Parametric Optical Design. 
40. Scroll to the bottom of the Section Aiming Properties table and change the % of Control Inside for Section 77 to 

be “100”, we will taper the % of Control Inside until we remove the undercut. For this lens this will be sections 
70-77. Section 77 - 100%, 76 - 100, 75 - 75, 74 - 50, 73 - 35, 72 - 20, 71 - 10, 70 - 5: 
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41. The lens profile is updated with the new parameters and the undercut is removed: 

 
42. Save the project. 
43. Begin the analysis and view your results. The beam has maintained the same general shape, however our pattern 

is not as smooth and we can see a step in the illuminance pattern, indicated with the red dashed circle below: 

 
Note  - The issue occurs because the light that is now controlled at the top of the inside surfaces refracts down 
sooner and misses the corresponding outside section. When those rays exit they refract in a slightly different 
direction than intended and the result is a striation in our pattern. 

 
44. Toggle off the “Illum.Planes” button, go to Right view, and Zoom Extents. 
45. Select the lens and go to View > Parametric Optical Design. 
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46. At the bottom of the Section Aiming Properties table, change the Aim Angle for sections 75-77 to all be “73” 
degrees. By aiming each section towards the same angle, we will actually add spread to that light since it will be 
exiting out through non-corresponding section of the exit surface. So the rays for those sections enters the lens, is 
aimed towards 73°, hits the exit face and refracts to a range of angles below 73° since the exit face has a 
changing curvature. 

47. With our lens aimed not as high vertically, we no longer need the last section, you can remove it by changing its 
weight to be “0”: 

 

 
48. Save the project. 
49. Begin the analysis and view your results: 

 
The beam is smoother and we have removed the undercut. The Diagonal profile of our lens design is complete 
and will serve as a foundation for the Across and Curb profiles. Note the intensity table at the low vertical angles 
since we will target these numbers in our following profile designs: 
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Curb Lens Profile Design 
50. Toggle off the “Illum.Planes” button, go to Right view, and Zoom Extents. 
51. Go to Settings > Layers, create a new layer named “REFR-Diagonal”, change the color to be green. Click OK to 

close the Layers Window. 
52. Select the lens, type “copy” into the command line, hit enter to copy in place. 
53. Select only the original lens, in Properties under General, change the Layer to “REFR-Diagonal”. 
54. Go back to Settings > Layers, turn the “REFR-Diagonal” layer off, and close the Layers window. You should just 

see the original lens in cyan which we will now develop to be our Curb profile. 
55. The lens profiles differ by being aimed to different vertical angles. The Diagonal profile must send the light the 

furthest distance to define our rectangular pattern, therefore it is aimed at the highest angle. The Curb profile will 
be aimed slightly lower at 67.5° vertically and will horizontally be pointed along the curb line. Select the lens and 
go to View > Parametric Optical Design. 

56. In the Aiming of Sections change the end aiming angle from “76” to “73” and click “Update Aiming”. This will 
remove the last three sections of our previous lens design. 

57. Using our experience from the Diagonal Lens without Undercuts design process, we will use the same % of 
Control Inside numbers at the top of the inside surface and we will adjust the final three aiming angles to all be at 
70.5°: 

58. Save the project. 
59. Begin the analysis and view your results: 
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Square Lofted Lens 
60. Besides aiming each profile at a different angle set to create a rectangular pattern, we want to ensure that our 

profiles will loft together smoothly to create a clean beam pattern. At this point we will create a lofted lens to 
create a square pattern (like you would use for Type V Square applications. Toggle off the “Illum.Planes” button, 
go to Right view, and Zoom Extents. 

61. Go to Settings > Layers, create a new layer named “REFR-Curb”, change the color to be blue. Turn on the 
“REFR-Diagonal” lens layer. Click OK to close the Layers Window. 

62. Select the Diagonal (green) lens, go to Design > Lens > Extract 2D Lens Profile. Hit escape to deselect the new 
profile copy. 

63. Select the Curb (blue) lens, go to Design > Lens > Extract 2D Lens Profile. Hit escape to deselect the new profile 
copy. 

64. Go to Settings > Layers, turn off both the “REFR-Diagonal” and “REFR-Curb” layers. Note that you have two new 
layers for each of the profiles that you just extracted, keep those layers on. Turn off the “Construction” layer Click 
OK to close the Layers window. 

 
65. Select the Curb profile (inside and smaller). Go to Top view. Type rotate into the command line (or go to Modify > 

Rotate), the base point is “0,0” and the rotation angle will be “-90”. 
66. Select the remaining Diagonal profile (which in Top view will be oriented along the Y axis pointing straight up), 

Rotate about “0,0” and “-45” degrees. 
67. Orbit in the CAD model so you can see your two lens profiles in relation to the LED: 
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68. Design > Lens > Loft 2D Lens Profiles, first select the Curb profile (along the X axis) and will display the aiming 

lines when selected. Then select the Diagonal profile. Hit enter to end selection. In the CAD view you will now see 
a simple lofted shape between the two profiles: 

 
69. Go to Top view, select the loft . In Properties under the Loft section, change Profile Symmetry to be Octalateral 

which will mirror and complete the loft around the LED. Hit escape to deselect the lofted lens: 
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70. The lens is no longer symmetric but is quadrilaterally symmetric. Go to Analysis > Specify Photometric Output, on 
the Photometric Report tab change your horizontal angle set to be “0(15)90”. Click OK to close the Photometric 
Output Specification window. 

71. Toggle on the “Illum.Planes” button and zoom extents. 
72. Save the project. 
73. Begin the analysis and look at the new pattern on the illuminance plane: 

 
74. While the pattern is square in shape, we see a distinct “X” pattern which indicates that our loft is not as smooth as 

it needs to be. Toggle off the “Illum.Planes” button, go to Front view, and Zoom Extents. 
75. Select the Curb lens profile, in Properties under the Weighting section change the Weight Exponent to be “1.675”. 

The lofted lens will automatically update to account for the adjusted parameter. 
76. Save the project. 
77. Begin the analysis and look at the new pattern on the illuminance plane: 
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As can be seen, the adjusted Weight Exponent for the Curb profile smooths out the loft and therefore the pattern. 
A square shape is still maintained but the beam is much more smooth and uniform. 

 

Curb Lens Profile Weight Adjustment 
78. Toggle off the “Illum.Planes” button, Right view, Zoom Extents. 
79. Go to Settings > Layers, create a new layer named “Square Loft” and turn the layer off. Turn on the “REFR-Curb” 

layer. Close the layers window. 
80. Select the lofted lens and the two extracted profiles and in Properties under General change the Layer to “Square 

Loft”. Those objects will disappear as they are now on a layer that is turned off. In the CAD view you should only 
see the Curb lens design (blue). 

81. Select the Curb lens and in Properties under Weighting change the Weight Exponent to “1.675” which is the value 
we used to smooth out the square lofted lens pattern. 

82. Under Edit > Design Properties, set the refractive “REFR-Curb” layer to be the Generic “ACRYLIC1” material. 
Close the Design Properties window. 

83. Save the project. 
84. Begin the analysis and view your results: 
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85. Open the Photometric Report and compare the candela distribution for the low angles to the Diagonal lens design 

from before: 

Diagonal Lens Profile 
Candela Distribution  

Curb Lens Profile 
Candela Distribution 

  

 
As can be seen the intensities are very similar across the low angles and this is what is required in order to 
produce a smoother loft and a smoother pattern. A similar intensity pattern will be the goal for the Across lens.  
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Across Lens Profile Design 
86. Toggle off the “Illum.Planes” button, go to Right view, and Zoom Extents. 
87. Go to Settings > Layers, create a new layer named “REFR-Across”, change the color to be red. Click OK to close 

the Layers Window. 
88. Select the Curb lens (blue), type “copy” into the command line, hit enter to copy in place. 
89. Select only one of the two Curb lenses, in Properties under General, change the Layer to “REFR-Across”. 
90. Go back to Settings > Layers, turn the “REFR-Curb” layer off, and close the Layers window. You should now see 

the Across lens in red. 
91. As noted before, the lens profiles differ by being aimed to different vertical angles. The Diagonal profile must send 

the light the furthest distance to define our rectangular pattern, therefore it is aimed at the highest angle, 70°. The 
Curb profile is aimed slightly lower at 67.5° vertically and will horizontally be pointed along the curb line. The 
Across profile will be aimed even lower at 60° and will be pointed straight ahead (along the +Y axis). Select the 
lens and go to View > Parametric Optical Design. 

92. In the Aiming of Sections change the end aiming angle to “66” and click “Update Aiming”. 
93. Using our experience from the Curb lens process, we will adjust the % of Control Inside numbers at the top of the 

inside surface and we will adjust the final three aiming angles to all be at “63.5” degrees. Additionally we will 
adjust the Weight Exponent to be “2.5”: 

 

 
94. Under Edit > Design Properties, set the refractive “REFR-Across” layer to be the Generic “ACRYLIC1” material. 

Close the Design Properties window. 
95. Save the project. 
96. Begin the analysis and view your results: 
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Back Lens Profile Design 
97. Toggle off the “Illum.Planes” button, go to Right view, and Zoom Extents. 
98. Go to Settings > Layers, create a new layer named “REFR-Back”, keep the color as white. Click OK to close the 

Layers Window. 
99. Select the Across lens (red), type “copy” into the command line, hit enter to copy in place. 
100. Select one of the two lenses, in Properties under General, change the Layer to “REFR-Back”. 
101. Go back to Settings > Layers, turn the “REFR-Across” layer off, and close the Layers window. You should just see 

the copied lens in white which we will now develop to be our Back profile. 
 
Note  - The house side portion of a roadway lens can be done many ways, in this case we will create a simple arc 
style profile that will decrease the amount of house side light by aiming some light forward. 
 

102. Select the lens and go to View > Parametric Optical Design. 
103. In Properties under the Weighting section, change the Weight Exponent to be “0”, in order to create a simple 

closed arc we will need to aim across a wider range of angles, but we don’t want to put more light towards the 
higher angles with the increased weight factor. 

104. In the Aiming of Sections change the start aiming angle to “-5” (so the light will be aimed slightly street side of the 
pole) and the end aiming angle to “85” and click “Update Aiming”. 

105. In the Section Aiming Properties table adjust the % of Control Inside so starting at section 54 (aimed at 48°) the % 
of Control Inside is 5%, then each subsequent line is 5% greater. Sections 73-91 will all be 100% control inside. 

106. In Properties under Offset Profile change the Minimum Thickness to “0.9”. Then change the Offset Distance to 
“2.0”.  

107. Save the project. 
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Asymmetric Lofted Lens 
108. Go to Settings > Layers, turn on the three street side lens layers (REFR-Curb, REFR-Diagonal, and 

REFR-Across). 
109. Select the Diagonal (green) lens, go to Design > Lens > Extract 2D Lens Profile. Hit escape to deselect the new 

profile copy. Go to Settings > Layers, turn off the “REFR-Diagonal” layer and close the Layers window. 
110. Select the Curb (blue) lens, go to Design > Lens > Extract 2D Lens Profile. Hit escape to deselect the new profile 

copy. Go to Settings > Layers, turn off the “REFR-Curb” layer and close the Layers window. 
111. Select the Across (red) lens, go to Design > Lens > Extract 2D Lens Profile. Hit escape to deselect the new profile 

copy. Go to Settings > Layers, turn off the “REFR-Across” layer and close the Layers window. 
112. Select the Back (white) lens, go to Design > Lens > Extract 2D Lens Profile. Hit escape to deselect the new profile 

copy. Go to Settings > Layers, turn off the “REFR-Back” layer and close the Layers window. 

 
113. Save the project. 
114. Select the Back profile (the smallest). In Top view rotate around “0,0” by 180°. 
115. In Right view select the Curb profile (the middle of the group of three profiles). In Top view rotate around “0,0” by 

-90°. 
116. In Right view select the Diagonal profile (the largest of the group of two profiles). In top view rotate around “0,0” by 

-47.5°. 
117. Orbit around in the CAD space and the four profiles and the LED should look like this: 
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118. Go to Design > Lens > Loft 2D Lens Profiles, select first the Back profile, then Curb, Diagonal, and last the Across 
profile. Hit enter to end selection: 

 
119. Go to Top view, select the lofted lens, in Properties under the Loft section, change Profile Symmetry to be 

“Bilateral Y” to mirror the loft. 
120. To keep the loft from coming to a sharp crease on the back side, in Properties under the Loft section, change 

Close Loft to be “Yes”. 
121. Adjust the loft resolution to be more smooth and uniform. In Properties under the Loft section, change the Vertical 

Resolution to be “80” and the Horizontal Resolution to be “100”. 

 
122. The lens is now bilaterally symmetric rather than quadrilaterally symmetric. Go to Analysis > Specify Photometric 

Output, on the Photometric Report tab change the Horizontal Angles to be “0(10)180” to capture both the forward 
and back light. Close the Photometric Output Specification window. 

123. Save the project. 
124. Begin the analysis and review your results: 
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Complete 
Congratulations! You have completed the Type III Roadway Lens Design tutorial. 
 
For more information and tutorials please visit our website at  www.ltioptics.com . If you have any questions don’t hesitate 
to reach out to our support team at photopia@ltioptics.com. 
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