
Advanced Tutorial – Analyze a Skylight Using the Sun & Sky Dome Models 

Prerequisites 

This tutorial is written with the assumption that you have already completed and understand the Beginner 
Tutorials under Help > Beginner Tutorials or in Chapter 3 of the User’s Guide. This tutorial does not 
therefore repeat all of the basic information about how to start a project, setup the analysis, run the 
raytrace and view the results. If you have not yet completed the Beginner Tutorials, then please do so 
before you proceed. 

Overview 

Photopia includes sun and sky dome “lamp” models for use in modeling daylight collection devices. 
These models are based on the IESNA RP-21 daylight equations that model the absolute illuminance 
from the sun (solar disk) at various altitude angles and the sky for various sky conditions and solar 
altitude angles. The sky domes include variable luminance values across the hemisphere as described in 
RP-21. The combination of both the sun and sky dome models produces a total illuminance onto the 
daylighting device area that is intended to match real outdoor conditions. Keep in mind that real 
conditions can vary widely and the RP-21 equations represent average conditions. 

This tutorial will describe how to use Photopia’s sun and sky dome lamp models for daylighting 
applications through an example. Given a particular location and skylight geometry, Part 1 of this tutorial 
will walk you through a daylighting analysis of the skylight. In Part 2, you will learn how to use scripting to 
analyze the skylight for multiple sun locations. The complete skylight geometry you will use is Skylight 
Tutorial.dxf, which should be located in your C:\Users\Public\Public Documents\LTI 
Optics\Photopia\Sample Projects folder (Windows 7) or C:\Documents and Settings\All 
Users\Documents\LTI Optics\Photopia\Sample Projects folder (Windows XP).  
 
 

Part 1: Analyze a Specific Sun Position 

Using the Daylighting Calculator 

We will analyze the skylight at noon on June 21, 2009 for a building located in Boulder, Colorado 
(approximate latitude 40°N and longitude 105°W). The first step is to calculate the sun’s position for this 
location and time. 

1. Use a spreadsheet program such as Microsoft Excel to open LTI Optics Daylighting 
Calculator.xls, which can be found under Help > Daylighting Calculator in Photopia. 

You can utilize this spreadsheet tool by entering values into the light blue cells and reading calculated 
values from the gray cells. We will use the first tool, titled “Enter Time & Location (Imperial Units)” on the 
Clear Sky Calculator page. 

2. Enter 40 for Latitude, 105 for Longitude, 12.00 for Time, and 6/21/2009 for Date. 
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In the gray cells beneath the cells into which we just entered data, notice the updated values for the 
various daylighting metrics. We will use the calculated Solar Altitude value of about 70 degrees to setup 
the Photopia model. 

3. Enter 1.167 for Diameter of Tube in feet, which is the diameter of the skylight in Skylight 
Tutorial.dxf. 

We now also have a value for the Total Input Lumens, which we will later use to calculate the skylight 
efficiency. 

Import the Skylight and Sun & Clear Sky Models 

4. Start Photopia, start a new project, and save it as 14in Skylight Boulder 6-21 Noon.ray. 

5. This project will be in inches, so make sure the project units are set to inches. This is indicated 
next to the coordinate readout in the lower left corner of the screen. You can change the units 
under Settings > Project Settings or by typing the UNITS command. 

6. Under File > Import CAD File > DXF/DWG, navigate to C:\Users\Public\Public Documents\LTI 
Optics\Photopia\Sample Projects (Windows 7) or C:\Documents and Settings\All 
Users\Documents\LTI Optics\Photopia\Sample Projects (Windows XP) to import Skylight 
Tutorial.dxf. Click Open and press Enter for the default units of inches. 
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Use orbit and zoom to view the skylight. Notice that there are three layers for the various skylight parts: 
the diffuser lens, the light tube, and the dome. After noting each layer’s color, we can ensure that the 
surfaces are oriented correctly. 

7. Right click in the CAD view and choose View Style > Show Surface Orientation. 

  
 

The surfaces need to be oriented towards the incident light, meaning that their respective layer colors 
should face the incident light. For light entering through the top of the dome, traveling through the inside 
of the tube, and exiting through the diffuser lens, it looks like we will need to re-orient all three surfaces. 

8. Select all surfaces and choose Modify > Orient. Enter R for reverse. 
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Based on the spreadsheet calculation from steps 1-3, we know that we need to use a solar altitude of 
about 70°. Solar altitude is the angle up above the horizon, so 10° is near the horizon and 90° is directly 
overhead.  We will import the Sun & Clear Sky lamp model for a 70° solar altitude and for the closest 
available aperture to 14”, which is the 1’ aperture size.  

9. From front view, under File > Import Lamp, choose Sun & Clear Sky-70 deg-1ft Aperture.LAMP. 
Enter an origin of 0,72 so that the bottom of the clear sky dome will line up with the bottom of the 
skylight entrance. 

 
 

Since the imported shield’s aperture size does not quite match the skylight opening size, we will now 
adjust it to fit correctly around the skylight opening. 

10. Click on the lower shield (the flat disc surrounding the skylight opening) to select it. You may have 
to use orbit to find it. 
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11. Choose View > Parametric Optical Design and change the Length parameter from 86 to 85. 
This is the distance from the outside of the shield to the aperture opening. Subtracting 1” from the 
original distance will change the aperture radius from 6" to 7", and the diameter from 12” to 14” to 
match the skylight opening. 

12. Zoom in on the skylight opening in CAD view to verify that the shield matches up properly. 

 

Setup the Raytrace 

13. Before the analysis is started, first assign materials under Edit > Design Properties. Under the 
Reflective tab, assign Alanod Miro 4 Silver to REFL-Light Tube. The REFL-Shield layer should 
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already be assigned with Generic ZERO0000 since this layer was imported with the sun/sky 
model. 

 
 

14. Under the Transmissive tab, assign Cyro Satin Ice to TRAN-Diffuser Lens and Generic 
POLYCRB to TRAN-Dome. Click OK. 

 
 

15. Then, under the Photometric Report tab in Analysis > Specify Photometric Output, set the 
horizontal angles of the candela distribution to (0(15)180) and keep the default of (0(5)90) for the 
vertical angles. Set the Luminous X and Y Dimensions to 14 each for the diameter of the skylight 
opening, and the Z Dimension to 0 since the skylight opening into the room has no luminous 
height.  
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16. Under the Illuminance tab, define an illuminance plane that is 40’ x 40’, 10’ below the skylight 
opening, using 100x100 columns and rows. Click OK twice to exit the Photometric Output dialog. 

 
 

17. Under Analysis  > Specify Raytrace Settings, change the Initial Source Rays to 100,000,000 
since a lot of the generated rays will be absorbed by the shield, not even entering the skylight. 
Change the Number of Ray Reactions to 50. Uncheck the Enable Ray Emanation Shadowing box 
since it is unnecessary for this application and causes a slower raytrace.  
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Analysis Results 

18. Choose Analysis > Begin Analysis to run the analysis.  

19. View output data by choosing View > Candela Distribution > Polar Plot, View > Illuminance > 
Shaded Plot, and View > Photometric Report. 
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The efficiency (LOR) shown in the Photopia report will be the ratio of the lumens exiting the skylight 
divided by the total lumens produced by the sun and sky dome models. The total lumens produced by the 
sun and sky dome models is very large compared to the total number of lumens that are actually incident 
onto the skylight itself. A more appropriate measure of the skylight efficiency is the ratio of the lumens 
exiting the skylight divided by the number of lumens incident onto it.  

20. To calculate the skylight efficiency, find the total number of lumens exiting the skylight under the 
Lumens Exiting System section of the Photometric Report. It should be a value close to 7418 
lumens. 

21. Take that value divided by the number of lumens incident onto the skylight, which we calculated 
in steps 1-3 to be 11,340 lumens. So the efficiency is about 65.4%. 

 
 

Part 2: Analyze Several Sun Positions with Scripting 

To simulate complete daily data with a range of solar altitudes, you must import the sun/sky model and 
run a raytrace for each solar altitude you wish to run. Instead of manually doing this work, we can run a 
script for Photopia to automatically run each raytrace, one after another, at a convenient time such as 
overnight. 
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Setting up a Base Project 

We will first setup a base project that will be used to import each solar altitude model. Since the skylight 
geometry and raytrace settings are already setup in the file from Part 1, we will make a copy of that file to 
start with.  

22. Make a copy the .ray file from Part 1, 14in Skylight Boulder 6-21 Noon.ray, and change the 
copied filename to 14inSkylight.ray. 

Photopia scripts do not work with filenames or file paths that include spaces, so make sure its full file path 
has no spaces.  

23. If the new .ray file is saved in a file path with spaces, move the file to a different folder with no 
spaces in the entire file path, creating a new folder if you wish. For example, move the file to 
C:\Photopia\SkylightTutorial. 

To turn the file into a base file for importing any solar altitude model, we need to delete the project’s 
current sky and sun models. 

24. Open the copied file, 14inSkylight.ray. 

25. Delete the sun model, the sky dome model, and the shield parts. All of these elements are 
included in each lamp file, so we will setup the script to import each file for each solar altitude. 
The skylight parts should be the only remaining geometry in the file. 

 
 

The available sun/sky files, which will be scripted to import into this base file, include 1’, 2’, or 4’ 
apertures, but our opening is 14” in diameter. We can use the 2’ files if we build a smaller shield to fill in 
the gap between the skylight and the 2’ opening. 

26. From front view, choose Design > Reflector: Polyline Based > Revolved to build a small shield 
that fits around this skylight opening. 

a. Enter a lamp center of 0,200 since this is the general area of the sun model and middle of 
the clear sky dome. 

b. Enter a start point of 7,72 to start the shield at the base of the skylight dome, which is 
where the roof line would start. 

c. Enter 12,72 for the next profile point so that the shield profile extends to the aperture 
opening of 2’ diameter, which is the file we will be importing though the script file. 
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d. Press enter again to end the profile. 

e. Choose 48 for the number of revolve segments. 

27. Click on the new shield to select it, and change its Layer (under General in the property control) 
to REFL-Shield. 

 
 

28. Save and close the project. 

Writing a Script 

Scripts can be stored in any location and they end with a .script extension. They are a text file that you 
can edit in notepad or any other plain-text editor. Each line contains a command. A semicolon represents 
the end of a command and is equivalent to a space or enter in Photopia's command line interface. 

29. Open a new file in a text editor such as Notepad. Save the file as 14inSkylight10-90.script. 
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30. Enter the following text into the file. The description of each text line is included below in red for 
your reference, but do not enter this descriptive text into your script file. 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Opens the specified file using the full file path. The file path 
cannot include spaces. 

Application.SuppressUserPrompts; 

Suppresses pop-up dialogs. This should be issued after every 
OpenProject command or else the script may be stopped due to 
a pop-up dialog box which waits for user input. 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight10.ray; 

Saves the project as a new name.  We will start with the 10° 
solar altitude. 

addlamp;Sun & Clear Sky-10 deg-2ft Aperture.lamp;0,0,72; 

Imports the specified lamp file at the specified location. 

RAYTRACE;NO; 

Initiates a raytrace analysis. The “NO” must be included to 
indicate that the raytrace should not run in a separate thread, 
which would cause the raytrace and the script to get out of sync. 

Application.SaveProject; 

Saves the file. 

Application.CloseProject; 

Closes the file. 

Application.FlushMessages; 

Forces Photopia to wait for a project to completely close before 
moving onto the next command. Should be issued after every 
CloseProject command. 
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31. Copy and paste the text entered from step 27 and alter the angle value (in BOTH the saved 
filename and the add lamp command) for each solar altitude you want to run. Below is the text for 
solar altitudes 20° through 90°. Note that you can only use solar altitudes in increments of 10° 
since that is what is included in the current Photopia library. 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight20.ray; 

addlamp;Sun & Clear Sky-20 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight30.ray; 

addlamp;Sun & Clear Sky-30 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight40.ray; 

addlamp;Sun & Clear Sky-40 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight50.ray; 

addlamp;Sun & Clear Sky-50 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight60.ray; 

addlamp;Sun & Clear Sky-60 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight70.ray; 

addlamp;Sun & Clear Sky-70 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight80.ray; 

addlamp;Sun & Clear Sky-80 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight90.ray; 
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addlamp;Sun & Clear Sky-90 deg-2ft Aperture.lamp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

  
 

Run the Script 

Now that the base project is setup and the script is written, choose a time to start the script when you will 
not necessarily need the memory on your computer, such as before you leave for the day.  

32. Open a new file in a text editor such as Notepad. Save the file as 14inSkylight10-90.bat, in the 
same directory as Photopia.exe, which is typically C:\Program Files (x86)\LTI 
Optics\Photopia\EXE\ (64 bit Windows) or  C:\Program Files\LTI Optics\Photopia\EXE\ (32 bit 
Windows). 

33. Enter Photopia /script=C:\Photopia\SkylightTutorial\14inSkylight10-90.script in this Windows 
Batch file. 

 
 

34. Save and close the new file. 
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35. Double click the batch file to run the script. 

All commands in your script will now run and your raytraces will be completed one after another. When 
you’re ready to work again the next morning, you should find all the new 14inSkylight##.ray files saved on 
your computer in the directory you specified, C:\Photopia\SkylightTutorial\ in this case, and you can open 
each of them to view their results.  


