
Advanced Tutorial – Designing a Linear Fluorescent Reflector with the 

Parametric Optical Design Tools 

Prerequisites 

This tutorial is written with the assumption that you have already completed and understand the Beginner 

Tutorials under Help > Beginner Tutorials or in Chapter 3 of the User’s Guide. This tutorial does not 
therefore repeat all of the basic information about how to start a project, setup the analysis, run the 
raytrace and view the results. If you have not yet completed the Beginner Tutorials, then please do so 
before you proceed. 
 

Design Overview 

This project will create an open 4-lamp T8 fluorescent luminaire with a reflector that produces a medium-
wide beam with a spacing criterion (S.C.) between 1.3 and 1.5. S.C. is the ratio of the spacing to the 
mounting height at which the illuminance half way between two luminaires equals the value directly 
underneath the luminaire. It therefore indicates the spacing that is achievable while maintaining relatively 
even illuminance. 

Getting Started 

1. Start Photopia and create a new project and save it as 4 Lamp 18W Strip Light.ray. 

2. This project will be done in mm, so make sure the project units are set to mm. This is indicated 
next to the coordinate readout in the lower left corner of the screen. You can change the units 

under File > Preferences or by typing the UNITS command. 

3. The luminaire is to be 600 mm long, so import an 18W tubular fluorescent lamp using File > 

Import Lamp. Choose the lamp model named F18-33. The complete list of lamps is found under 

the Library > Lamp List menu. Insert the lamp at 0,0,0. 

4. Go to front view. Your CAD view should look like the following image. 
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The reflector will first be made around a single lamp and then it will be arrayed to make a 4 lamp 
luminaire. Note that if the complete luminaire will be an array of the same reflector profile around each 
lamp, then it is best to work with the single reflector until the desired distribution is achieved. Then the 4 
lamp array can be made. Each iteration of the reflector design will benefit from quicker analyses when 
using only a single lamp. 

The reflector profile can be started from either directly over the top of the lamp or from the outer rim. The 
choice to start your reflector from either point usually depends on  your constraints. If you are using a 
specific length lamp holder for example and the reflector must therefore start at a specific distance from 
the lamp center, then it is best to use the point directly over the lamp as the start point. In this case, you 
need to iteratively determine the exact angular extent of the reflector to obtain a specific reflector width. If 
you have flexibility on the distance between the reflector and the lamp, which depends on how your lamp 
holder is mounted, then you might find it easier to start the reflector at a point on the end of the reflector 
opening so that you can fix its width to a specific value. This example will start the reflector over the top of 
the lamp and an assumed lamp holder length of 20 mm from the reflector to the lamp center. 
Furthermore, the reflector will also start with a flat reflector segment that is 25 mm wide so that the lamp 
holder can easily be snapped into this segment and the reflector can easily be mounted to the housing. 

5. Choose Design > Reflector: Polyline Based > Extruded Symmetric.  

a. Accept the default of 0,0 for the lamp center. 

b. Enter 0,20 for reflector start point and @12.5,0 for the next point. Then press Enter when 
prompted for another point to end the polyline. 

c. Enter 600 for the extrusion length. The reflector should look like the following image. 

 
 

Design an Aiming Based Reflector 

The curved reflector that will control the bulk of the distribution will start where the flat polyline-based 
reflector ends. To ensure it will always start where the first reflector ends, we can link the two together. 
Reflectors are linked by name, so we first need to name this reflector.  

6. Select the flat reflector in the CAD view and enter Flat in the Name property of the main property 
control in the right side of the screen. 

7. Now choose Design > Reflector: Aiming Based > Extruded Symmetric.  

a. Accept the default lamp center. 
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b. For the start point, just click a point on the screen near the end of the right side of the 
reflector. We will link the reflectors after this reflector is created.  

c. To enter the angular extent, hold down the Ctrl key and then move your mouse to the 
right and down to sweep an angle clockwise (CW) about the lamp center. Sweep an 
angle about 45⁰ below the X axis. 

d. To choose an initial set of reflector aiming angles, we should look at our S.C. goal. If we 
aim for an S.C. of 1.4, this means that light should be aimed at least toward half way 
between two luminaires spaced 1.4 times their mounting height apart, or 0.7, and this is 
an angle of 35⁰ from nadir. So, specify 0⁰ for the first section and -35⁰ for the last section.  

e. Accept the default of 5⁰ as the aiming angle increment. 

f. Then enter 600 for the extrusion length. 

 
 

8. After the reflector definition is finished, select it and choose Flat from the drop down list in the 

Start Linkage property under Start & Extent in the main property control.  

 
 

We will assume each of the 4 reflectors can be 115 mm wide. We will therefore set the widest point to 
which this reflector can expand to be 57.5 mm to either side of the lamp center. We now need to find the 
reflector angular extent that results in a reflector that is this wide.  

9. To help in doing this, create a new layer named Construction, make it yellow, and choose DASH 
for Line Type in the layers dialog. Also make this layer current.  
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10. Then use the LINE command to create a vertical line from 57.5,20 to 57.5,-100.  

 
 

11. Now select the aiming based reflector and change its Extent property to a larger value than you 
originally specified. After arriving to an Extent value of -111⁰, the reflector appears to be the right 

width. This value was arrived at iteratively and may need to change later after the reflector aiming 
parameters are changed. 
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Setup the Raytrace 

Now that we have an initial reflector design that aims light to the range of angles we desire and is about 
the right width, we can analyze its performance to see how close we are to our S.C. goal.  

12. Before the analysis is started, first assign Alanod Miro 4 to the REFL-Main layer that was created 

for our reflector in Edit > Design Properties.  

 
 

13. Then, in Analysis > Specify Photometric Output, set the horizontal angles of the candela 
distribution to (0(15)90) and keep the default of (0(5)90) for the vertical angles. Set the Luminous 
Z Dimension to 0 since this luminaire will eventually have end caps and have no luminous height. 
Also define an illuminance plane that is 10m x 10m, 3.5m below the luminaire, using 100x100 
columns and rows. We will use this plane to judge the smoothness of the beam. 
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14. Under Analysis  > Specify Raytrace Settings, change the Initial Source Rays to 500,000 to start 
with to get a quick analysis of the reflector. If its performance is close to what we are seeking, 
then we will increase the number of rays. If the performance is significantly off, then we will keep 
the number of rays low and manipulate the reflector parameters until we get close before 
increasing the resolution of the analysis. This will allow you to get close to the results you desire 
more quickly. 

 

Analysis Results & Design Iterations 

15. Run the analysis. Under View > Photometric Report, we see that the reflector results in an S.C. 

of 1.40 in the 90⁰ plane, the plane in line with the cross section of our reflector and thus the plane 

we are controlling. Also, the candela distribution looks like the following image. 
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16. Since these results are close to what we want, we will run more rays to get a smoother candela 
distribution and see the details that need to be addressed. Running 5,000,000 rays results in the 
following candela distribution and illuminance distribution. 
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The general shape of the candela distribution did not change much with more rays but the illuminance 
plane is much clearer. Although this design has the general beam width we desire, it has some striations 
in the beam pattern that are undesirable. There are several possible ways to address these, so we will 
experiment with various reflector parameters in order to see their effects. First of all, note that the current 
reflector uses the default values for the Curve Resolution in the property control. This defines the 
smoothness of the reflector profile, essentially the angular size of the reflector facets that approximate the 
parabolic aiming sections. The default value is 4⁰, which defines a fairly smooth reflector. See Chapter 5 

of the manual for more details about this parameter. The following image shows the reflector mesh with 
the default curve resolution.  

 
 

You can see several reflector facets in each reflector aiming section. The more precisely the shape of the 
individual parabolic sections is defined, the more likely it is that the reflector will create individual spikes of 
light toward each aiming angle, which are spaced 5⁰ apart. The large lamp will provide spread from each 

reflector section and help blend the beam, but even with a 4⁰ curve resolution, this spread is not enough to 

avoid the striations in the light pattern. One technique for spreading the light even further is to decrease 
the precision of this reflector and make each reflector aiming section a flat segment. The flat segments 
will spread light to a wider range of angle than a parabolic curved section.  

17. In order to get a single flat segment for each reflector section, enter 90⁰ for the Curve Resolution 

parameter. Since the total angular extent of each section is less than 90⁰, Photopia will only create 

a single facet for each section. The reflector will now look like the following image. 
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18. Run the analysis after this change. The results are shown below. You can see a significant 
smoothing in the beam as a result of the larger reflector facets.  
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If you require even further smoothing, then you can try some additional changes. One option is to increase 
the number of aiming angles. The reflector still uses the original 5⁰ steps between the individual aiming 

angles. We accepted that default because we had no reason to choose something different at that time. If 
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a reflector has too few facets aimed at angles that are too far apart, then you can sometimes have 
difficulty in smoothing out striations. So we can try redefining this reflector with 2.5⁰ increments between 

the aiming angles yet keeping a single face for each reflector section.  

19. This can easily be done by opening the View > Parametric Optical Design screen. Enter 0(2.5)-
35, representing the start angle, increment, and ending angle for the reflector sections, in the text 
box in the Aiming of Sections portion of the screen and click the Update Aiming button. You will 
then see the same general reflector shape but with more aiming sections. 

 
 

20. Running the raytrace with the increased number of aiming angles results in the following 
performance. 
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The increased number of aiming angles did help fill in the dark stripe that was in the beam center in the 
previous analysis, but the difference in performance might not be large enough to justify the potential 
increase in manufacturing cost of creating the higher number of facets. This depends on the 
manufacturing method. If the reflector is made on a break press, then each bend has a cost so you have 
an incentive to keep them to a minimum. If the reflector is made on progress rollers however, then there 
will be no increase in cost and you should take the higher number of aiming angles. 
 



 13 Advanced Tutorial – Linear Fluorescent Reflector 

Array the Reflector 

Now that the single reflector performance is satisfactory, we will create an array of four reflectors that are 
all still parameterized and can be changed together. To do this, we will use the Array parameters in each 
reflector’s property control. (Remember we have two reflectors, the flat top and the aiming based.)  We 
will assume that each reflector gets a total width of 120mm. This gives us 5mm to create a return in the 
reflector if it was made from a single piece or if the pieces were fastened together.  

21. From the front view with the CPlane set to this view, move the lamp and reflectors to the left by 
180mm. (You can turn off the Construction layer since it isn’t really needed any longer.) 

 
 

Different from the CAD Array function which simply arrays a reflector or other geometry to make new 
ones, using the Arraying section in the properties control creates arrayed reflector images that are actually 
a property of the reflector itself. That way, when you make changes to the reflector profile, those changes 
will also be updated in the arrayed parts of the reflector. 

22. Select the flat top reflector in the CAD view and find the Arraying section of its property control. 
Choose Rectangular as the array type. Enter 4 for Num Columns and 120 as the Colum Spacing. 
Deselect this reflector and select the curved reflector to enter the same values in its Arraying 
section.  
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23. Next array the lamp with the Modify > Array command on the main menu. Enter the same 
rectangular array parameters. The final reflector and its results are shown in the next few images. 
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