Beginner Tutorial 1 - Importing with the Luminaire Import Wizard

Shown below is an LED collimator optic and holder created in external CAD software. This tutorial will
show how to import this model into Photopia. Photopia may import STL, DWG, or DXF geometry files. For
more information on how to export these files from your CAD software, see our website:
http://www.ltioptics.com/en/support-photopia-2015.htmli#cad
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Get Started in Photopia

1. Open the Photopia stand-alone program.

Since Photopia supports multiple projects to be opened at the same time, it starts without any project
open. This allows you to either select an existing project or start a new one. For this tutorial, you will be
starting a new one.

2. Choose File > New from the main menu.

3. This project will be done in millimeters, so make sure the project units are set to mm. The units
are indicated next to the coordinate readout in the lower left corner of the screen. You can change
the units by typing the UNITS command into the command prompt.

Import CAD files into Photopia

We will begin by importing the luminaire assembly CAD files into Photopia via the Luminaire Import
Wizard. This wizard combines the process of importing the luminaire/optic geometry and the lamps/LEDs.
There are two options for the wizard: one that imports DXF/DWG files and one that imports STL files. This
tutorial will use the STL file option.

To import the luminaire CAD files into Photopia:

4. Select File > Import Luminaire Wizard > STL from the main menu.


http://www.ltioptics.com/en/support-photopia-2015.html#cad
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5. Navigate to the folder to where the STL files were exported. For this tutorial, find the STL files in
C:\Users\Public\Public Documents\LTI Optics\Photopia\Sample Projects\LED Collimator\.

6. Hold the Shift key and click to select all the STL files with names starting with LED Collimator...

Import STL File(s) x
— v <« Photopia » Sample Projects » LED Collimator v (o] 2
Organize = New folder Sl i 0

LED Collimator Mame Date modified Type Size
Photopia r'} LED Collimator - Collimator-1.5TL 3/21 1.813 KB
& OneDrive B LED Collimator - Holder-1.5TL 72 KB
"} LED Collimator - LED CREE XPL-1.5TL 649 KB
£ This pC ') LED Collimator - PCE-1.5TL 1KB

o Autodesk 360
[ Desktop
| Documents

4 Downloads

J\. Music

| Pictures

m Videos

e Win8 (C:)

e Data (D2)

W
File name: |"LED Collimator - PCB-1.5TL" "LED Collimatar - Collimatar-1.5T] v| Stereolithography Files (*stl*b ~

7. Click the Open button. Photopia then displays the Import Model screen.




Beginner Tutorial 1 — Import a Luminaire

Import Model X

Select Layers For Import

[#1LED Collimator - Collimator-1 (Mon &
LED Collimator - Holder-1 (Non Opt
LED Collimater - LED CREE XPL-1
LED Collimator - PCE-1 (Mon Optici »

< >
Layer Type: | Non Optical ~
Layer Colar ‘ |||||H!--W“--”lpllu:s: |Illl||""|“”",”||| " |

Units . .
Drawing: Millimeters v o
Photometric: ) | ; ;
Position

Translation Rotation

3" Mz | X ~

; DD Angle: %

Aoply Aoply
Set Origin @
Geo Center

Next = Cancel

The layer list box in the upper-left corner contains a list of the STL files, where each becomes a layer in
Photopia. Layers that are checked will be imported and are shown in the CAD view. Make sure that all
layers beginning with LED Collimator... are checked.

Also notice that each of these layers includes a type designation specified in parentheses (scroll to the
right). The "LED CREE XPL" layer should remain Non Optical. We need to use a Photopia lamp model for
the lamp (rather than this imported CAD lamp layer).

8. The "Collimator" layer will refract and totally internally reflect (TIR) light, so change the layer type
by clicking that layer and changing the item in the Layer Type list box to Refractive.

9. Since the “Holder” and “PCB” layers will reflect light, change the layer type for these layers to
Reflective. You can use the Shift and Ctrl keys to select multiple layers.
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10. The Units for the drawing are shown in the list box below the list of layers. Be sure that the

drawing units are set to Millimeters.

The geometry that will be imported is shown in the CAD view on the right side of the screen. You can
manipulate the CAD view with the mouse. Right clicking in the CAD view exposes a pop-up menu with

numerous display options.

11. Right click in the CAD view and choose Dynamic Views > Orbit. Now you can change your view
of the luminaire by left clicking and dragging the mouse in the CAD view. Find the origin, which is

indicated by a circle with crosshairs.

It looks like the luminaire needs to be translated and rotated to make it centered at the origin with the light
aimed in the negative z direction, which would be the correct position and rotation.
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12. Under Translation, click Set Origin @ Geo Center and then click Apply.
13. Right click in the CAD view and choose Zooming > Zoom Extents.

The luminaire is now centered at the origin.
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14. Right click in the CAD view and choose Standard Views > Right View. The luminaire is aiming
the light to the left, but it should aim downward, in the negative z direction.
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15. Under Rotation, select X for Axis, enter 90 for Angle, and click Apply. The luminaire is now aiming

the light downward. Click Next.
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The Orient Surfaces screen will open. Here you can specify the method that Photopia will use to
determine surface orientation. When importing closed meshes (as in this tutorial), Photopia will
automatically orient the surfaces correctly and the surface orientation functions are not necessary. You
can use the CAD view to examine the orientation of the surfaces.

16. Right click in the CAD view and choose Dynamic Views > Orbit. Surfaces will be rendered in
their layer color when viewed from their “front” side and the opposite color when viewed from their
“back” side. The layers are currently white, so all of the surfaces should appear white. You can
also hold the Ctrl key and click the lens layer to deselect it from the Layers To Orient list. This will

allow you to view the surfaces behind the lens.

Orient Surfaces
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LED Collimator - Holder-1 (Reflective)

< >

Surface Orientation
Methed
(®) To A Paint
() Direction

(_) Reverse

Select All Surfaces
Orient Surfaces To A Paint

x:[0 ] @Toward Point
- D () Away From Point
AU

X

< Back Next > Cancel

17. Click Next to go to the Add Lamp window. You may insert lamps in this screen or in the Photopia
CAD view after we end the wizard. Click Finish to end the wizard and add the LED later.

18. A question may pop up in the screen asking how to handle geometry on duplicate layers (if some
same-named layers already existed in the new project). Since the new project had no geometry,

there is no risk of overwriting geometry. Click No.

Luminaire Import Wizard

existing Layers?

geometry is used.

Duplicate layers were imported by the Wizard, Merge imported geometry onto

Yes - Imported geometry is merged onto existing layers.
No - Duplicate layers and geometry in the model are deleted and the imported

19. A save dialog may automatically pop up if the project has not yet been saved. Save the project as
Beginner Tutorial - LED Collimator.ray in a location of your preference.
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20. The Design Properties screen will automatically pop up. It is better to go through the Design
Properties after we have added the lamps, so click OK for now and we will come back to this
screen later.

Import the Lamp

Now that all of the luminaire geometry is imported, we can import the lamp model into the luminaire. The
“LED CREE XPL” layer included in the imported geometry indicates the LED location. We can give each
layer its own color and we can isolate the “LED CREE XPL” layer so that we can easily see where the
lamp model needs to be located.

21. Choose Settings > Layers from the main menu. Here you can see a list of all of the layers in the
project, along with their individual properties. Change some of the layer colors by clicking on a
layer's color and then choosing a color from the drop-down menu that appears.

Layers X

urrent Layer: LED Collimator - Collimator-1

SOLID ! Non Optical
|— LED Collimator - Collimatar-1 SOLID ! Refractive
|— LED Collimataor - Holder-1 SOLID Reflective

|JLED Collimator - LED CREE XPL-1 [ ] ‘h:llcm-a SOLID

LED Collimator - PCE-1 SOLID _

22. To isolate the “LED CREE XPL” layer, use the Ctrl or Shift keys while clicking to select all of the
layers except that layer. Click on one of the selected layer's "On" indication for the drop-down
menu to turn those layers Off. Click OK.

Layers *

urrent Layer: LED Collimator - Caollimator-1

W White
1] Cyan
D Red SOLID

1| LED Collimator - LED CREE XPL-1 E_ O Vellow SoLD _

[ |LED Collimator - PCB-1 W White SOLID 1 Reflective

The CAD view now shows just the LED geometry.
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23. Choose File > Import Lamp from the main menu. Find and click the XP-L-5700K.LAMP file, and
click Open. (Note that a detailed list of the lamp models available is located under Library >
Lamp List in the main menu.)

Import object from library file X
1 « ProgramData » LTl Optics » Library » Lamps v | 0 Search Lamps P
Organize « Mew folder S o
Lamps ™ Name Date modified Type Size "
Photopia | XP-G2-3100K.LAMP LAMP File 138 KB
XP-G2-CW.LAMP LAMP File 134 KB
@ OneDrive Y . .
| XP-G2-WW.LAMP LAMP File 54 KB
[ This PC | XP-G3-4000K.LAMP LAMP File 469 KB
5 Autodesk 360 | XP-G-EZW.LAMP LAMP File 552 KB
I Desktop | XP-L2-6500K LAMP LAMP File 160 KB
. XP-L-3000K.LAMP LAMP File 115 KB
=| Documents - - —

) | XP-L-5700K.LAMP LAMP File 115 KB
¥ Downloads | XP-L-H1-5800K.LAMP LAMP File 52 KB
b Music | XP-L-HI-5700K.LAMP LAMP File 24 KB
&=| Pictures | XQ-D-WW.LAMP 6/21/2 LAMP File 296 KB
m Videos | XQ-E-4B4NM.LAMP M LAMP File 96 KB

Wing (C) | XQ-E-521NM.LAMP 5 5PM  LAMP File 96 kB
i D0 s amL aisesilivtin e
v £ >
File name: | XP-L-5700K.LAMP v| Lamp File (*.lamp) ~
-

24. You are now able to click a lamp center location for the new lamp model. Click near the center of
the displayed LED geometry. We will come back to refine the position.
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25. Click the new LED model to select it, being careful not to select the previous CAD model as well.

The selected model will display as pink.

L] Beginner Tutorial - LED Collimator.ray

Lo & s

You can adjust the LED location in the property control screen, located to the right of the CAD view.

26. Under Geometry, change the Origin X value to 0 and the Origin Y value to 5.5.
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Now the new LED model appears to be located in the proper position.

27. Choose Settings > Layers. Turn On all of the layers. Turn the “LED Collimator — LED CREE
XPL-1" layer Off now that we have imported and located the Photopia lamp model.

Layers *

Current Layer: LED Collimator - Collimator-1

Name On Color Line Type Line Width Layer Type
LAMP-XP-L-5700KCORE1 On [ (255,255,127) SOLID 1.000000 Lamp
LAMP-XP-L-5700KCORE2 On [ (255,255,127) SOLID 1.000000 Lamp
LAMP-XP-L-5700KCOREA On L White SOLID 1.000000 Lamp Axis
Layer 1 On [ White SOLID 1.000000 Non Optical
LED Collimator - Collimator-1 On O Cyan SOLID 1.000000 Refractive
LED Collimator - Holder-1 On SOLID 0000 Reflective

; Non Optical
LED Collimator - PCB-1 On [ White 50LID 1. Reflective

REFL-LEDBLKBASE-XP-L-5700K On I (128,128,128) SOLID 1.000000 Reflective
REFL-LEDLEADS-XP-L-5700K On O (255,191,0) SOLID 1.000000 Reflective
REFL-LEDWTBRD-XP-L-5 On L White SOLID 1.000000 Reflective

REFR-DOWMS1002-XP-L-5700K On [ White SOLID 1.000000 Refractive
REFR-LEDWHITEBOARD-XP-L-5700K On [ White SOLID 1.000000 Refractive

New Delete Set Current Trim Common Prefix oK Cancel

28. Click the Zoom Extents icon E@ to view the model.
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B | £D Collimator

Design Properties

Now that the lamp is included in the project, we can return to the Design Properties screen by choosing
Edit > Design Properties. The Design Properties screen contains a summary of the optical components
of the project.

The Lamp tab shows the LED lamp location listed. Here you may alter the initial lamp lumens, the radiant
watts, the electrical wattage for the lamp, or the ballast/driver wattage.

Design Properties *
lamp  Reflective Refractive  Transmissive
LED 3.0975W cool White (1.05A) (core only) ~
Lamp Locations Lumens : 46167 per lamp
X Y pd
Radiart Watts : |1.41408 perlamp
0.00 5.50 0.00
Blectrical Wattage : |3.0575 per lamp
Ballast/Driver Wattage © |[0.20975 per lamp
Layer Material
LAMP-XP-L-5700KCORE1 LEDPHOS
LAMP-%P-L-5700KCOREZ2  LEDPHOS
Cancel

The other tabs allow you to complete the specification of the optical geometry you have imported by
assigning materials to the different layers.

Assign Materials

Photopia provides a library of reflective, refractive, and transmissive materials, depending upon the edition
purchased. You must assign materials to the specific layers of your design before an analysis can be
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completed. Multiple layers of the same type (e.g. multiple Reflective layers) must be used if different
materials are to be assigned to those components.

This tutorial contains only reflective and refractive layers, thus there will be no layers listed in the
Transmissive tab. Note that the Refractive tab will not be visible unless purchasing Photopia Premium. To
assign materials to the reflective layers:

29. Select the Reflective tab from the Design Properties screen.

Design Properties X
lamp Reflective Refractive Transmissive
Layer Name Designation Description Reflectance
LED Collimator - PCB-1
REFL-LEDLEADS-XP-L-5700K LEDLEADS LED metal lead material 80.00
REFL-LEDBLKBASE-XP-L-5700K LEDELKBASE LED black plastic material 10.00
REFL-LEDWTBRD-XP-L-5700K LEDWTERD LED white PCBE material 85.00
LED Callimator - Holder-1
£ >
Assign Material
QK Cancel Apphy

Some layers already have materials assigned to them; these are layers that were imported with the LED
lamp model.

30. Select the “LED Collimator — PCB-1” layer and click the Assign Material button. This displays the
Material Selection screen.

31. Scroll down the list of materials to the Generic section and choose White PCB. Click OK.

Material Selection
I anufacturer [Drezignation Description % Reflection 0
Generic wihite ABS white 85 plastic T4
Generic ‘whhite Acmylic white acrylic 95
Generic CB white PCE material
Generic ‘white Fubber white ubber material hal
Generic ZEROOO0D black surface 1]
Genesiz Plastics Walar white farmed plastic art 98
Genesiz Plastics ‘Walar 0.55 white formed plastic 96
Genesiz Plastics “Walar 0.80 white farmed plastic 96
Genesiz Plastics Walar=<T white formed plastic 96
H.B. Fuller PAINT OO pre-paint white steel 93
[[]] 4410 white TR-1 glogsy white thermoset plastic 93
101 4410 wWhite TR-2 light texture on white thermazat plastic 93
Jordan HD 10 anodized alumn. a7
Jordan 554 textured anodized alum. 23
Labsphere SPECTRLM Spectralon, diffuse white 99.3
Larin PureBrite 804 zemi-zpec. hazy alurn. a7
M. K. Feflec. MakSsPOm specular clad alum, i3
Mitzubizhi Plagtice HISHIMETAL Ex-DR white plastic laminated metal 95
Mitsubizhi Plastics HISHIMETAL EX-RS white plastic laminated metal 94
Mitzubizhi Plagtice HISHIMETAL /T white plastic laminated metal 94
< Nl R - =
Cancel
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32. Select the “LED Collimator — Holder-1” layer and click the Assign Material button. This displays

the Material Selection screen.

33. Scroll down the list of materials to the Generic section and choose PAINTO007, a white paint that is

87% reflective. Click OK.

Material Selection
M anufacturer Dezsignation Deszcription % Reflection "
Generic PaIMT 00 white paint a6
Generic PAIMT 002 white paint a3
Generic PAIMT 006 white paint a0
int
Generic FRFALZ0T presfinish, spec. alzak
Generic SANDELASTAH 11580 4L, sand blasted & anodized 77
Generic SATIMNOM zatin, zemi-zpec. alum. a2
Generic SPEC1O specular suface 10
Generic SPEC 100 zpecular zuface 100
Generic SPEC 20 specular suface 20
Generic SPEC 30 specular suface an
Generic SPEC 40 specular suface 40
Generic SPECHD specular suface A0
Generic SPECED specular suface B0
Generic SPEC 0 specular suface it}
Generic SPEC A0 specular suface an
Generic SPEC 800 specular double sided an
Generic SPEC 81D specular double sided M
Generic SPEC 820 specular double sided a2
Generic SPEC 830 specular double sided a3 w
B . . L - N
Cancel

34. Click the Refractive tab at the top of the Design Properties screen.

35. Click the "LED Collimator — Collimator-1" layer and click Assign Material. Choose Generic

ACRYLICL1 for the lens material. Click OK.

Material Selection

Manufacturer Deszignation Diescription Index of Refraction ~
Abrisa Sandblast Sandblast on PC 1.586

Abriza Solite Solite ptrr om aciylic 1.491

Abriza Solite Saolite ptrn on PC 1.586

Bayer LECPC LED polycarbonate 1.586

B ayer LEDPCLUY % LED polycarbonate 1.586

Coarning FRE=D01 Pures 1.474

Diow Coming M5-1002 high Shore & hardness injection moldable optical silicone 1,42

Diow Coring 51003 medium Shaore A hardness injection moldable optical sili..  1.42

C C1 standard C

Generic ACRYLICISPD SPD 250-2800nm - standard acrylic 1.491

Generic AlR air 1

Generic AirFused Silica 254mm - air outside/fused slica inside 1.50482

Generic ALUMACRA vacuum metalized alun. on acrylic 1.491

Generic ALUKMPOLT wacuum metalized alum. on polycarbonate 1.586

Generic BOROSILI borasilicate crown glazs 1.52

Generic DIFFACR1T zandblast acrylic 1.491

Generic DIFFFCE1 sandblast polycarbonate 1.586

Generic Fuzed Silica SPD SPD 133-3710nm - fuzed siica 1.458

Generic Fuzed Silica- VT 50 Water  25d4nm - fused silica outzide/water inside 1.37648

Generic Fused Silica-UVT 70Water  254nm - fused silica outside/water inside 1.37648 v

< B e e . R - L R N
Cancel

36. Now that the materials have been assigned, click OK to close the Design Properties screen.

37. Save the project by choosing File > Save.



