
Beginner Tutorial 2 – Analyze a Luminaire 

Once a 3D luminaire model is inside Photopia and its materials are assigned, it is ready to be analyzed. 
Photopia allows you to specify a range of settings that control the analysis process and also dictate the 
type and format of the photometric output produced. The following sections lead you through the details of 
specifying the photometric output and raytrace settings.  
 

1. Before starting, choose Help > Open Sample Project and find Beginner Tutorial – LED 
Collimator.ray, if it is not already open from Tutorial 1. 

Photometric Output 

2. Select Analysis > Specify Photometric Output from the main menu. This screen allows you to 
select the type(s) of output Photopia will generate. Your choices include a Photometric Report and 
Illuminance on a Plane. Additionally, you can specify whether the photometry will be Relative, 
Absolute, or Per Thousand Lamp Lumens.  

 
 

Relative photometry is based on the lamp lumens specified in the Design Properties screen (the rated 
lamp lumens). Absolute photometry is based on the total output lumens (the rated lamp lumens, 
decreased by the system optical efficiency). Photometry reported per thousand lamp lumens is scaled so 
1000 total lumens were input into the luminaire. If the luminaire in this tutorial were photometered using 
per thousand lamp lumens, it would be assumed that each of the two lamps generated only 500 lumens.  

3. For this tutorial, choose Photometric Report and Illuminance on a Plane for the output types, and 
Relative for the output scaling. 

 

Photometric Report  

4. Select the Photometric Report tab to specify the details of your photometric report.  
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This screen allows you to choose a report type, photometry type, the horizontal and vertical angles in the 
distribution, test distance, decimal precision, photometric center, and luminous dimensions. The following 
sections provide a brief description of each of these items. 

 
 

File Format 

Photopia will create standard format photometric files as part of its output. Even though you may specify a 
file format in this screen, Photopia automatically creates all formats when you run a raytrace. The files 
created are an IES file (North American standard), EULUMDAT files (European standard) and a TM-14 
file (British standard). The files are stored with your project files in the folder you specified, using the name 
of your project as its filename prefix. In this tutorial, Photopia will create files named Beginner Tutorial – 
LED Collimator.IES (IES file format), Beginner Tutorial – LED Collimator.T14 (TM-14 file format), Beginner 
Tutorial – LED Collimator.LDT and Beginner Tutorial – LED Collimator.ELX  (both EULUMDAT file 
formats).  
 

Report Type 

Photopia also automatically creates photometric reports. The specific format of the photometric reports 
generated by Photopia can be tailored to the needs of the specific type of luminaire you have. Photopia 
generates reports appropriate for indoor luminaires, floodlight luminaires, and roadway luminaires. Since 
the luminaire in this tutorial is a fluorescent troffer, we will leave the default of Indoor report type. 
 

Photometry Type 

The photometry type you select determines the orientation of the horizontal and vertical angles in the 
candela distribution as well as the constraints on these angles (as a matter of convention) set forth by the 
Illuminating Engineering Society of North America (IESNA). Indoor luminaires can be photometered with 
either Type A or Type C photometry. These photometric types define spherical coordinate systems with 
the poles of the coordinate system directly below (at nadir) and directly above (at zenith) the luminaire. 
The IES recommends that indoor luminaires be photometered as Type C. For more details about 
photometric types and the horizontal and vertical angles associated with them, see Chapter 6. 
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Type A & C Coordinate System 

 

Specifying Horizontal and Vertical Angles 

The horizontal and vertical angles determine the exact mesh or web of points to be sampled in the 
spherical coordinate system. Both the horizontal and vertical angles are specified as a list of angles using 
the following syntax: Start Angle (Angular Increment) Stop Angle. Commas are used to separate individual 
angles or ranges of angles, thus (0,5(10)85,90) is the same as (0,5,15,25,35,45,55,65,75,85,90). Spaces 
are not allowed. You can choose pre-defined angle sets from the lists provided, or define your own by 
typing them in using this convention.  

5. Choose 0 for the horizontal angle set and 0(2.5)90 for the vertical angle set.  

The complete range of the horizontal angles runs from 0° to 360°. We chose 0° since our luminaire is 
essentially axially symmetric. This means that all horizontal angle data will be averaged with symmetry.  

The complete range of vertical angles runs from 0° to 180°. We chose 90° as a stopping point since our 
luminaire is a direct luminaire (it directs all of the light downward). No symmetry is assumed with vertical 
angles. If we had a completely indirect luminaire (one that directs the light toward the ceiling), then we 
would have selected vertical angles ranging from 90° to 180°. If we had a direct/indirect luminaire (one 
that directs light up and down), then we would have selected an angle set ranging from 0° to 180°. 
 

Test Distance 

The test distance refers to the distance from the photometric center to the virtual photocell used to 
measure the amount of light in a given direction. Luminous intensity distributions (candela distributions) 
can vary depending on the test distance used. In general, candela distributions stabilize and approach a 
constant shape if the test distance is greater than five times the maximum dimension of the luminaire. 
Thus the luminaire in this tutorial, which is about 10mm in diameter, may be kept at the default of 6.1m. 
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Decimal Precision 

The decimal precision refers to the number of decimal places that will be written to the photometric files. 
For most luminaires, two decimal places will suffice. However, if you have a low output luminaire, such as 
an emergency luminaire where the expected candela values are all quite low, then you may want to 
choose a higher number for the decimal precision to obtain the proper resolution in your calculated data. 
Keep the default of 2 for this tutorial.  
 

Photometric Center 

The default value for the photometric center is usually 0, 0, 0. If you wish to change the default 
photometric center, then enter the desired location in the cells provided. For this tutorial, the photometric 
center should be located in the aperture of the luminous opening. In this drawing, this location is at a Z 
height of about –7.2mm.  

6. So enter a Z value of –7.2 and leave the X and Y values both at 0 for this tutorial.  
 

Luminous Dimensions 

Photopia uses the luminous dimensions of the luminaire and the calculated candela values to estimate 
average luminaire brightness values for certain viewing angles. By default Photopia uses the physical 
extents of the luminaire for these dimensions. However, there are many cases where this assumption is 
not correct, and you may therefore enter the dimensions that should be used. Any recessed luminaire 
such as the downlight in our tutorial is an example of a luminaire for which you would want to modify the 
dimensions. In particular, you need to change the luminous height (Z dimension) to 0 since the sides are 
not luminous.  

7. Uncheck the checkbox for Use Physical Extents from CAD Model and enter a Z value of 0. 

 
 
 



 5 Beginner Tutorial 2 – Analyze a Luminaire 

Illuminance on a Plane 

8. Once you have entered all of the photometric report information, select the Illuminance tab. 

 
 

Photopia allows you to specify as many illuminance planes as you like. For each plane you must define its 
location and grid density. Additionally, you can deactivate planes you do not wish to participate in 
calculations using the checkbox at the bottom of this screen.  

9. We will specify only one plane for this tutorial, so enter a 1 into the Number of Planes cell. 

Illuminance planes are defined relative to the absolute location and orientation of the luminaire in the CAD 
drawing. The luminaire in this tutorial is centered near 0, 0, 0 and the light is directed in the -Z direction. 
This is the orientation the luminaire should have in order for the horizontal and vertical angles, specified in 
the photometric report, to have meaning. For more details on the construction of a luminaire in the CAD 
program, see Chapter 4. 

Illuminance planes are defined by four corner points, three of which you must provide, as shown in the 
following illustration. For more information on illuminance planes, see Chapter 6. 
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Illuminance Plane 

 

The illuminance plane for this tutorial will be 5m x 5m in size, centered 3m below the luminaire. The grid 
density will be 100x100 bins. With this information you can now define the illuminance plane: 

10. Select the Illuminance Plane 1 from the list.  

11. Click the Define Plane button. Photopia displays an Illuminance Plane pop-up screen.  

12. Edit the Description by typing in 5m x 5m Plane, 3m Below. 

13. The location of the plane is specified by four corner points. The descriptions of these points, for 
example, Lower Left Corner, refers to the location of the point you wish to view on a page. Be 
aware of the units for the illuminance plane coordinates, shown in the bottom left corner of this 
screen. Assuming the units for this tutorial are in meters, enter -2.5, -2.5, -3 for the Lower Left 
Corner point.  

14. Enter 2.5, -2.5, -3 for the Lower Right Corner point. 

15. Enter -2.5, 2.5, -3 for the Upper Left Corner point. 

16. The Upper Right Corner point will be calculated automatically. 

17. The default number of columns and rows gives a grid density of 100x100. 
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18. Once you have all of your values properly entered, click the OK button on the Illuminance Plane 
pop-up window. Once you have finished with all of the photometric output specifications, click the 

OK button. 

Note that you will be able to see your illuminance plane in the CAD view inside Photopia, so it should be 
clear if you did not enter your coordinates properly.  

19. Click the Isometric View icon and the Zoom Extents icon  to view the model. 

 

 

If your plane looks like it is the wrong size or in the wrong location, then check the units of the plane 
coordinates and ensure you entered numbers appropriately for that unit.  
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Specify the Raytrace Settings 

Select Analysis > Specify Raytrace Settings from the main menu. This screen allows you to set the 
parameters that control the raytrace and the display of the results. The following sections provide a brief 
description of each of these items. 

 
 

Initial Source Rays 

The Initial Source Rays refers to the total number of rays that will be emitted from all of the light sources. 
In general, the more rays specified, the more accurate your photometric output. However, the output 
accuracy becomes asymptotic at some point.  

It is generally the case that the resolution of your output defines the level of the raytrace you require. A 
single value like optical efficiency may be calculated accurately (to the point at which it is not changing any 
further) in as little as 50,000 rays. Accurate candela distributions can take anywhere from 2,500,000 to 
5,000,000 rays, depending on the number of lamps in the luminaire and the size of the angular zones in 
your candela distribution. A high-resolution image of an illuminance plane using a grid density of 100 x 100 
or more, could take 10,000,000 rays or more to produce a smooth looking image.  

When a raytrace analysis is done with too few rays, the results are scattered and spiky when the ultimate 
result is actually smooth and contained. This behavior comes from the nature of the calculations, where 
the rays are randomly emanated from light sources and scattered upon interactions with materials. The 
emanation and scattering directions are driven by probabilities, meaning that only after many rays do the 
patterns embedded in the probabilities become evident. The more rays, the more the final patterns 
emerge.  

A luminaire such as the one in this tutorial will show relatively smooth output at the level we have specified 
using 2,500,000 rays. You can therefore keep the default number of rays. 
 

Number of Reactions 

The number of reactions traced determines how far a ray will be followed before it is disregarded. A 
reaction is defined to be an intersection with a surface. For surfaces that are purely reflective, one reaction 
reflects an incident ray into its resulting direction. For surfaces that are transmissive, one reaction 
intersects the surface, then probabilistically transmits or reflects a ray. For surfaces that are refractive, one 
reaction intersects the entrance surface, then probabilistically refracts or reflects a ray, and for the 
refracted rays, a second reaction intersects the exit surface, then probabilistically refracts or reflects a ray, 
and so on. Keep the default of 25 reactions for this tutorial. 
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Ray Emanation Shadowing 

The last item in the Basic Raytrace Parameters section controls the ray emanation shadowing feature in 
Photopia. Lamps having surfaces that block the view of each other from an outside viewpoint, (e.g. a 
compact fluorescent lamp with its multiple tubes or the filament support structure in a quartz halogen 
lamp) need to have special checking enabled in the calculations to ensure light does not pass through any 
surfaces which shade other surfaces.  
 

Advanced Raytrace Parameters 

These will not be used in this tutorial, so keep the default settings. 
 
 
 

Display Tab 

20. Click the Display tab. 

 
 

Analysis Update Frequency 

Under the Display tab, the analysis update frequency specifies how often all of the output you are viewing 
is updated as the raytrace process proceeds. Keep the default value of 10% for the tutorial and you will 
get to view your calculated output as soon as 10% of the analysis is completed. You can then observe 
how the output changes and iterates every 10% toward a smooth result as more rays are traced. 
 

Ray Posting to Geometry View 

Photopia can display a sample of 3D rays from the raytrace so that you can view them and how they 
interact with your luminaire. You can specify the number of rays and the length of the last ray segment 
after it exits the luminaire. Check the Add 3D Rays to Project checkbox if you want to see the rays in 
Photopia's CAD view. For this tutorial we will leave this option turned off. 
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21. Click OK to exit the Raytrace Settings screen. 
 

Run an Analysis 

Now that we have completed all of the necessary steps preparing our analysis, we can start the raytrace.  

22. Select Analysis > Begin Analysis from the main menu.  

On the program’s bottom toolbar you can see the progress of the calculations. After the first analysis 
update, you will see an estimated time of completion. While the analysis is running, you can terminate the 

analysis at any time. To do so, select the Analysis > Terminate Analysis from the main menu. A 
terminated analysis cannot be resumed and will restart from the beginning once you choose Begin 
Analysis again. 
 

View the Photometric Output 

While the analysis is running, we are able to view the calculated output as it updates. The first view of the 
output will be available after the calculations reach 10% (our specified update frequency).  

View the Photometric Report 

Begin with the photometric report.  

23. Select View > Photometric Report from the main menu. Photopia displays the formatted report 
generated for the luminaire. You can scroll through the report by using the up and down arrow 
buttons located on the right side of the screen. Chapter 6 provides more details on the data in the 
report. 
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View the Candela Distribution Polar Plots 

24. To display a polar plot of the candela values, select View > Candela Distribution > Polar Plot 
from the main menu. To watch the polar plots change at each update of the results, bring up the 
polar plot at the start of the raytrace.  

 
 

View the Illuminance Plane Data 

Photopia gives you the option of viewing the illuminance plane data in several different ways. You can 
view the data as text in tabular form, a contour plot, a color shaded plot a gray-scale shaded plot, or a 
false color plot. You can also view the data directly on the illuminance plane shown in the CAD views.  

25. To view the data in text form, select View > Illuminance > Text from the main menu.  

26. To view the data as a color shaded plot select View > Illuminance > Color Shaded Plot. Next, 

select the illuminance plane name and click the OK button. 

27. To view the color shaded plot in the CAD view, click on the CAD view window for the project. Then 
pick the edge of the square defining the illuminance plane with your mouse (left-click). It will be 
shown in pink when it is selected. The properties of the illuminance plane will be shown in the 
property control at the right side of the screen. Click on the property for Display Plot under 

Display and change the default value from False to True. Then press Esc on your keyboard to 
de-select the illuminance plane. You will now see the color shaded plot.  
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Saving the Output 

You can print any of the output views by clicking in the view to make it the active view, and selecting File > 

Print Active View from the main menu. You can also save the views to a BMP file or save any vector 
based view to a DXF or DWG file by right clicking in the view and choosing the export option accordingly.  


